4/26~27 RIP 등 실습 정리*
- -
@Haemin_R
en
show ip int brief
conf t
hostname Haemin_R
int fa0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
int fa0/1
ip address 192.168.2.254 255.255.255.0
no shutdown
end
show run
copy run start
show ip int brief
show ip route
@Donga_R
en
show ip int brief
conf t
hostname Donga_R
int fa0/0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
int fa1/0
ip address 192.168.2.253 255.255.255.0
no shutdown
exit
int fa1/1
ip address 192.168.4.254 255.255.255.0
no shutdown
end
show run
show ip int brief
show ip rotue
copy run start
@Jiyun_R
en
show ip int brief
conf t
hostname Jiyun_R
int fa0/0
ip address 192.168.5.1 255.255.255.0
no shutdown
exit
int fa1/0
ip address 192.168.4.253 255.255.255.0
no shutdown
exit
int fa1/1
ip address 192.168.6.254 255.255.255.0
no shutdown
end
show ip int brief
show run
show ip route
copy run start
@Daun_R
en
show ip int brief
conf t
hostname Daun_R
int fa0/0
ip address 192.168.7.1 255.255.255.0
no shutdown
exit
int fa0/1
ip address 192.168.6.253 255.255.255.0
no shutdown
end
show run
show int brief
show ip route
copy run start
각 라우터의 설정파일 확인 #show run
show ip int brief 인터페이스 상태 up up확인
show ip route 라우팅 테이블 확인 ©
*각 네트워크 내에 ping test
@Haemin_R#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES manual up up
FastEthernet0/1 192.168.2.254 YES manual up up
Vlan1 unassigned YES unset administratively down down
Haemin_R#ping 192.168.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
Haemin_R#ping 192.168.2.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.253, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
Haemin_R#
@Donga_R#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.3.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet1/0 192.168.2.253 YES manual up up
FastEthernet1/1 192.168.4.254 YES manual up up
Vlan1 unassigned YES unset administratively down down
Donga_R#ping 192.168.2.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Donga_R#ping 192.168.4.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.4.253, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
Donga_R#ping 192.168.3.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
Donga_R#
@Jiyun_R#
Jiyun_R#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet1/0 192.168.4.253 YES manual up up
FastEthernet1/1 192.168.6.254 YES manual up up
Vlan1 unassigned YES unset administratively down down
Jiyun_R#ping 192.168.4.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.4.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
Jiyun_R#ping 192.168.6.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.6.253, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
Jiyun_R#ping 192.168.5.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/0 ms
Jiyun_R#
@Daun_R#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.7.1 YES manual up up
FastEthernet0/1 192.168.6.253 YES manual up up
Vlan1 unassigned YES unset administratively down down
Daun_R#ping 192.168.6.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.6.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
Daun_R#ping 192.168.7.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.10, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/1 ms
Daun_R#
*Dynamic Routing Protocol: RIP 하는 법
en
show ip route connected
c x.x.x.x
c y.y.y.y
conf t
router ?
rip
network x.x.x.x
network y.y.y.y
end
show run
show ip route
(rip할때 연결된 네트워크들 다 써줘야함. ex) R1에 바로 옆에 연결된 네트워크가 N1.0과 N2.0이면 -> Network 192.168.1.0
Network 192.168.2.0)
<실습>
*Haemin_R - rip setup
en
show ip route connected (직접 연결된 네트워크 확인-rip전달)
C 192.168.1.0
C 192.168.2.0
conf t
router rip (라우팅프로토콜rip 프로세스 켜기)
network 192.168.1.0 (rip이 전달하고자 하는 network 선언)
network 192.168.2.0
end
show run 입력한 명령어 확인
show ip route 라우팅 테이블확인
copy run start 저장
*Donga_R
en
show ip route connected
C 192.168.2.0
C 192.168.3.0
C 192.168.4.0
conf t
router rip
network 192.168.2.0
network 192.168.3.0
network 192.168.4.0
end
show run
show ip route
copy run start
*Jiyun_R
en
show ip route connected
C 192.168.4.0
C 192.168.5.0
C 192.168.6.0
conf t
router rip
network 192.168.4.0
network 192.168.5.0
network 192.168.6.0
end
show run
show ip route
copy run start
*Daun_R
en
show ip route connected
conf t
router rip
network 192.168.6.0
network 192.168.7.0
end
show run
show ip route
copy run start
각 라우터에 네트워크 정보가 모두 올라오는지 확인. 시뮬레이션모드에서 RIP 정보를 잡아보기 (auto capture)
show ip protocols
show ip route
c
c
c
R
S -> 이렇게 Static이 있고 Rip는 없는 경우-> show ip protocols 입력 후 확인-> S를 복사해서 앞에 no [Static 주소] 를 입력해서 삭제하기
(*메트릭 값이 동일한 경우 최대 4개까지 라우팅 테이블에 올라감.(but, 메트릭 값이 작으면 작은거 먼저 올라감)메
ex) fa0/0 x.x.x.x [120/5]
fa0/1 x.x.x.x [120/0] <- 얘가 먼저 올라감)
* passive-interface 확인법
router rip
? <- 여기서 패시브 확인 후
passive-interface fa0/0
<실습>
holddowntimer
|
|-----|-----|-----|-----|-----|-----|------|-----|-----|-----|-----|-----|-----|-----|
| |
유효하지않는시점 삭제되는시점
Haemin_R#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 10 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip 재분배
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 2 1
FastEthernet0/1 1 2 1
Automatic network summarization is in effect 자동썸머리 기능 on
Maximum path: 4 (metric 값이 동일할 경우, 최대 4개의 경로가 일스톨됨)
Routing for Networks:
192.168.1.0
192.168.2.0
192.168.6.0
Passive Interface(s): (rip정보를 차단하는 인터페이스)
Routing Information Sources:
Gateway Distance Last Update RIP정보를 전달하는 게이트웨이
192.168.2.253 120 00:00:03
Distance: (default is 120) AD값
Haemin_R#
R1 fa0/0-------------networkA [120/5]
fa0/1-------------networkA [120/5]
Dynamic Routing protocol은 활성화 되어있는 모든 인터페이스로 라우팅 정보를 전달.
RIP UDP 520 port
Haemin _R
fa0/0, fa0/1로 전달되는 rip정보 확인해보기.
lab2 192.168.1.0 ~ 192.168.7.0 classful network -> 네트워크 변경
Haemin_R fa1/0 172.16.1.0/24
Daum_R fa1/0 172.16.2.0/24
*Haemin_R : add interface
en
show ip int brief
fa1/0
conf t
int fa1/0
ip address 172.16.1.1 255.255.255.0
no shutdown
end
show ip int brief
show run
*Daun_R : add interface
en
show ip int brief
fa1/0
conf t
int fa1/0
ip address 172.16.2.1 255.255.255.0
no shutdown
end
show ip int brief
show run
추가한 네트워크를 rip이 추가 전달할 수 있도록 rip설정
네트워크 선언을 추가하기
*Haemin_R
en
show ip route connected
C 172.16.1.0
conf t
router rip
network 172.16.0.0
end
show run
show ip route
show ip protocols
copy run start
*Daun_R
en
show ip route connected
C 172.16.2.0
conf t
router rip
network 172.16.0.0
end
show run
show ip route
show ip protocols
copy run start
*Haemin_R, Daun_R
show run -> 172.16.0.0
show ip protocols -> 172.16.0.0
*Donga_R, Jiyun_R
show ip route
*모든 라우터의 rip에 subnetmask를 주고받고록 rip version2로 변경하기
en
conf t
router rip
version 2
end
*summary 기능이 켜져있음
172.16.1.0/24 -> 172.16.0.0
자동 summary 기능을 꺼야 서브넷팅된 sm를 전달가능함.
*모든 라우터의 rip에 auto-sumary 끄는 법
en
conf t
router rip
no auto-summary
end
show run
show ip protocols
Automatic network summarization is not in effect
4개 라우터 rip version 2로 동일해야함.
라우팅 테이블에 network 정보가 모두 올라오는지 확인
pc들끼리 ping test
'Network' 카테고리의 다른 글
4/29 STP* (0) | 2021.04.29 |
---|---|
4/28 Link-State Routing Protocol, OSPF (0) | 2021.04.28 |
4/27 라우팅, Looping 방지하기 위한 기술들, RIP 등 정리 (0) | 2021.04.28 |
4/27 Static/Dynamic Routing (0) | 2021.04.28 |
Cisco 라우터3대 IP주소 할당, ping test, Static Route 설정, RIP, v2설정 (0) | 2021.04.28 |
소중한 공감 감사합니다